Не работает NametagEdit

wayinfo

Пользователь
Собственно, после сброса LuckPerm'a до версии 4.4.0 из-за не работающего AuthMe (теперь работающего), NametagEdit при хуке с LuckPerm'ом выдает такую прикольную ошиб(очку) >>
Код:
[16:36:21] [Server thread/ERROR]: Error occurred while enabling NametagEdit v4.4.6 (Is it up to date?)
java.lang.NoClassDefFoundError: net/luckperms/api/LuckPermsProvider
at com.nametagedit.plugin.hooks.HookLuckPerms.<init>(HookLuckPerms.java:19) ~[?:?]
at com.nametagedit.plugin.NametagEdit.onEnable(NametagEdit.java:54) ~[?:?]
at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:264) ~[minecraft_server.jar:git-Spigot-2cf50f0-2b93d83]
at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:337) [minecraft_server.jar:git-Spigot-2cf50f0-2b93d83]
at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:403) [minecraft_server.jar:git-Spigot-2cf50f0-2b93d83]
at org.bukkit.craftbukkit.v1_12_R1.CraftServer.enablePlugin(CraftServer.java:381) [minecraft_server.jar:git-Spigot-2cf50f0-2b93d83]
at org.bukkit.craftbukkit.v1_12_R1.CraftServer.enablePlugins(CraftServer.java:330) [minecraft_server.jar:git-Spigot-2cf50f0-2b93d83]
at net.minecraft.server.v1_12_R1.MinecraftServer.t(MinecraftServer.java:422) [minecraft_server.jar:git-Spigot-2cf50f0-2b93d83]
at net.minecraft.server.v1_12_R1.MinecraftServer.l(MinecraftServer.java:383) [minecraft_server.jar:git-Spigot-2cf50f0-2b93d83]
at net.minecraft.server.v1_12_R1.MinecraftServer.a(MinecraftServer.java:338) [minecraft_server.jar:git-Spigot-2cf50f0-2b93d83]
at net.minecraft.server.v1_12_R1.DedicatedServer.init(DedicatedServer.java:272) [minecraft_server.jar:git-Spigot-2cf50f0-2b93d83]
at net.minecraft.server.v1_12_R1.MinecraftServer.run(MinecraftServer.java:545) [minecraft_server.jar:git-Spigot-2cf50f0-2b93d83]
at java.lang.Thread.run(Thread.java:748) [?:1.8.0_222]
Caused by: java.lang.ClassNotFoundException: net.luckperms.api.LuckPermsProvider
at java.net.URLClassLoader.findClass(URLClassLoader.java:382) ~[?:1.8.0_222]
at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:152) ~[minecraft_server.jar:git-Spigot-2cf50f0-2b93d83]
at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:100) ~[minecraft_server.jar:git-Spigot-2cf50f0-2b93d83]
at java.lang.ClassLoader.loadClass(ClassLoader.java:424) ~[?:1.8.0_222]
at java.lang.ClassLoader.loadClass(ClassLoader.java:357) ~[?:1.8.0_222]
... 13 more
 

q20w26a

Разработчик
Пользователь
Проблема та же, как и с Authme была. Ждите новую версию NTE.
Если Вы используете старый LuckPerms и новый NTE - вероятно NTE будет работать только с новым LuckPerms. Попробуйте старую версию NTE.
 

BuseSo

Разработчик
Пользователь
Попробуй поставить другой плагин на таб. Например, тот же Tab (кликабельно)
 

wayinfo

Пользователь
Попробуй поставить другой плагин на таб. Например, тот же Tab (кликабельно)
Попробую поставить, отпишу если все будет работать без ошибок.
Проблема та же, как и с Authme была. Ждите новую версию NTE.
Если Вы используете старый LuckPerms и новый NTE - вероятно NTE будет работать только с новым LuckPerms. Попробуйте старую версию NTE.
Ставил 4.2.1 NTE, по прежнему ошибка с хуком LuckPerms.
 

Комнаты в чате

Верх Низ