Не могу добавить яйца спавна в меню (не работает data value)

Mr_dsa1

Пользователь
Здравствуйте. Делаю магазин на скайблоке и мне нужно добавить в магазин яйца призывов, но проблема в том, что как бы я не пытался получается вот это -
Загрузка любых файлов разрешена только на наш сервер.
Использовал плагины: DeluxeMenu, ChestCommands (ни в одном из них не получилось), версия сервера 1.10
 
Последнее редактирование модератором:

MrGold

Пользователь
В последних версиях DM пишется не ID, а название предмета, а потом data.

Пример:
YAML:
      Test:
        material: MONSTER_EGG
        data: 50
        slot: 40
        display_name: ''
В результате получим яйцо призыва крипера.
 

Mr_dsa1

Пользователь
В последних версиях DM пишется не ID, а название предмета, а потом data.

Пример:
YAML:
      Test:
        material: MONSTER_EGG
        data: 50
        slot: 40
        display_name: ''
В результате получим яйцо призыва крипера.
Странно, вот что получилось (по быстрому проверял на другом меню):
Код:
YAML:
    items:
      '1':
        material: MONSTER_EGG
        data: 50
        slot: 14
        update: true
        display_name: '&a&l► &6&lТест &a&l◄'
        lore:
        - ''
        - 'Тест!'
        - ''
        left_click_commands:
        - ''
        right_click_commands:
        - ''
Внешний вид:
Загрузка любых файлов разрешена только на наш сервер.
 
Последнее редактирование модератором:

MrGold

Пользователь
Странно, вот что получилось (по быстрому проверял на другом меню):
Код:
YAML:
    items:
      '1':
        material: MONSTER_EGG
        data: 50
        slot: 14
        update: true
        display_name: '&a&l► &6&lТест &a&l◄'
        lore:
        - ''
        - 'Тест!'
        - ''
        left_click_commands:
        - ''
        right_click_commands:
        - ''
Внешний вид:
2019-08-04_2043.png
Версия DM какая?
 

The_stas

Команда форума
Администратор
Извиняюсь, но вроде есть разница в версии сервера по поводу команд выдачи. Лучше обновить сервер до, хотя бы, 1.12.2. 1.10 была промежуточная версия и косяки в ней не убирали.
 

Mr_dsa1

Пользователь
Извиняюсь, но вроде есть разница в версии сервера по поводу команд выдачи. Лучше обновить сервер до, хотя бы, 1.12.2. 1.10 была промежуточная версия и косяки в ней не убирали.
Хорошо, завтра постараюсь обновить сервере и скажу результат
 

The_stas

Команда форума
Администратор
Хорошо, завтра постараюсь обновить сервере и скажу результат
Версии плагинов обнови.
WorldEdit (обязательно)
WorldGuard (обязательно)
Могут пропасть регионы после обновления WorldGuard !!! Спавн и так далее. проверь
 

Mr_dsa1

Пользователь
Версии плагинов обнови.
WorldEdit (обязательно)
WorldGuard (обязательно)
Могут пропасть регионы после обновления WorldGuard !!! Спавн и так далее. проверь
Понимаю, чувствую завтра будет весело, WG и WE - у меня не единственные, которые скорее всего слетят после перехода.
+ у меня весь серв на 1.10, то есть придется каждый по отдельности обновлять, я просто всё никак не решался, но после возникновения нескольких проблем, которые исправит только переход - вижу придется.
 

Комнаты в чате

Верх Низ